「指定したプログラムには、新しいバージョンの Windows が必要です」というエラーが表示されました - Visual Studio Skip to content
「指定したプログラムには、新しいバージョンの Windows が必要です」というエラーが表示されました2020-04-07T11:29:27-07:00

Visual Studio 2015 に関する FAQ

マイクロソフトにはどのような支援ができるでしょうか。

「指定したプログラムには、新しいバージョンの Windows が必要です」というエラーが表示されました

症状

Windows 7 SP1 以上が既にインストールされているコンピューター上に Visual Studio 2015 をインストールしようとすると、Visual Studio インストーラーにはより新しいバージョンの Windows が必要であるというエラー メッセージが表示されます。

screenshot of Visual Studio installer newer version of Windows

解決策

Windows ランタイムのバージョンを不適切に低下させる自動適用された互換性設定が原因で、Visual Studio 2015 のインストール中にこのエラーが表示されることがあります。 この問題を回避するには、Visual Studio インストーラーの互換性設定を削除します。

  1. [Visual Studio インストーラー] アイコンを右クリックします。
  2. [プロパティ] > [互換性]タブの順に選択します。
  3. [すべてのユーザーの設定を変更] を選択します。
  4. [互換モードでこのプログラムを実行する: ] を選択解除します

    screenshot of Win Newer Version Error Solution

  5. [OK] をクリックします。
  6. 構成ウィンドウを終了します。
  7. Visual Studio インストーラーをもう一度起動します。

    screenshot of VS Installer

サポートに戻る

フィードバック