Я получаю сообщение об ошибке: “Для указанной программы требуется более поздняя версия Windows”. - Visual Studio Skip to content
Перейти к основному контенту
Visual Studio
Я получаю сообщение об ошибке: “Для указанной программы требуется более поздняя версия Windows”.2020-04-07T11:29:28-07:00

Вопросы и ответы по Visual Studio 2015

Как мы можем помочь?

Я получаю сообщение об ошибке: “Для указанной программы требуется более поздняя версия Windows”.

Проблема

Вы хотите установить Visual Studio 2015 на компьютере, где уже установлена Windows 7 с пакетом обновления 1 (SP1) или более поздняя версия, но выводится сообщение о том, что установщику Visual Studio требуется более поздняя версия Windows.

screenshot of Visual Studio installer newer version of Windows

Решение

Пользователи могут столкнуться с этой ошибкой во время установки Visual Studio 2015 из-за автоматически применяемых параметров совместимости, которые неправильно сокращают время выполнения Windows. Чтобы решить эту проблему, удалите параметры совместимости в установщике Visual Studio.

  1. Правой кнопкой мыши щелкните значок Установщик Visual Studio.
  2. Выберите пункт Свойства, откройте вкладку Совместимость.
  3. Выберите Изменить параметры для всех пользователей.
  4. Снимите флажок Запустить программу в режиме совместимости с

    screenshot of Win Newer Version Error Solution

  5. Нажмите кнопку ОК.
  6. Закройте окно настройки.
  7. Запустите установщик Visual Studio.

    screenshot of VS Installer

Вернуться к поддержке

Обратная связь