Feedback

/I received the error “This version of Visual Studio requires a computer with a newer version of Windows!”
Visual Studio 2015 Support | Visual Studio 2018-05-17T08:30:10+00:00

Visual Studio 2015 FAQ

Back to Support

How can we help?

I received the error “This version of Visual Studio requires a computer with a newer version of Windows!”

Symptom

When attempting to install Visual Studio 2015, you receive the message: "This version of Visual Studio requires a computer with a newer version of Windows!". Visual Studio 2015 minimum operating system requirement is Windows 7 with Service Pack 1 (or higher).

Resolution

1. Download Service Pack 1 (SP1)

You can download and install SP1 for Windows 7 from Microsoft.com for free.

2. Confirm that SP1 is installed by following these steps

  1. Click Start, right-click Computer, and then click Properties.
  2. Check the Windows edition section: If Service Pack 1 is listed, Windows 7 SP1 is already installed on your computer.

3. Launch the Visual Studio installer again

Back to Support