Skip to content
I received the error “This update requires Visual Studio 2015 Update 3 to be installed”2020-06-23T10:52:21-07:00

Visual Studio 2015 FAQ

How can we help?

I received the error “This update requires Visual Studio 2015 Update 3 to be installed”

Symptom

When you try to install Visual Studio 2015 security updates, you receive a “This update requires Visual Studio 2015 Update 3 to be installed” error message. However, you can verify that Visual Studio 2015 Update 3 (KB3022398) was installed.

Cause

You have to also download and install KB3165756. KB3165756 is a critical and required performance update to Visual Studio 2015 Update 3 (KB3022398). KB3165756 is automatically downloaded and installed when you do new installations of Visual Studio 2015 that are sourced from official Microsoft locations. However, some organizations create their own offline layouts, and they may not know to first update the Update 3 contents by using KB3165756. For more information, see

Resolution

  • Make sure that you have Visual Studio 2015 Update 3 (KB3022398) installed.
  • Install performance update KB3165756.
  • Start the Visual Studio Installer, and verify that Help > About shows version 14.0.25431.
Back to Support

Feedback